Weird issue: I can't disable turbo loading!